Groundwire Push Settings

I’m looking at Groundwire on iOS’s push settings, is there a recommendation for the various options? In particular for, I’m not sure about:

  • Simulate Nat
  • Synchronous Registration
  • Single Instance

Hello @thedaveCA,

I am on Android, and I did not change the default settings. I have “Simulate NAT” ON, “Single Registration” OFF. The other I do not see.

I hope this helps. :blush:

Do you see any failures to connect when launching the client? I invariably have at least one line report a failure, although eventually it does connect.

I’m thinking that depending on how handles multiple registrations, they might be causing a conflict. I know it isn’t a good idea to have multiple “normal” VoIP clients/phones on the same subaccount, and that it is recommended to create a unique subaccount for each device.

Never had up to yesterday. But I must say that I am in Europe right now (instead of Canada) and had to use server. And I see that Groundwire is struggling to have a stable connection (solid green status connection). It has it, but it flickers from grey to green sometimes.

So is it because of the new server, something with, or something else. I do not know at this point. But it is still able to connect.

Up to last week I never saw this kind of behaviour.

I set up MicroSIP on my desktop to do some testing and when I have two softphones connected to the same subaccount, both can dial out, but only the most recent to have registered gets the inbound calls.

This seems to me to Single Instance (which I think is the one you don’t see on Android?), in the app this is described as “Enable if your provider does not support multiple registrations and newer registrations replace the previous one”.

But I’d like to know for sure what is recommended from the server side.

Hello @thedaveCA,

Having two devices on the same SIP account is calling for trouble. Both devices will fight for the registration. The last one who got it will receive the calls. If you are never using both devices at the same time, this is fine. Otherwise, you should have two SIP accounts, one for each device. Then use a ring group to make them ring both.

This is probably why you have this registration issue. :blush: Not exactly the same as what I am experiencing.

No, I absolutely agree. I was just testing to confirm’s behaviour to try to confirm what Groundwire’s settings should be.

Groundwire’s defaults do not seem well suited to as the default behaviour is multiple registrations. It partially covers this up since whether the push server or local client is connected doesn’t matter, since the push server forwards the call.

But there will be a point between where the client disconnects and the push server re-registers where calls won’t come through. Changing the aforementioned switch should help.

1 Like