Colleague's Android phone gets de-registered

This is more of a VOIP question in general, rather than something specific to VoIP.ms, but I don’t know where to start. I have several users who take VOIP calls via the GroundWire app on their smartphone. Everyone’s is working fine except for one user, who’s listing on the VoIP.ms page goes from “registered” to “No registration found”. I assume the app is failing to maintain the connection during a long period of activity. But I don’t even know how it’s supposed to work. Does the app need to contact the server periodically? What is that called? Is there a setting that would make that fail? Thanks.

Hi @aerosol,

Is this user also using GroundWire with push notification or another softphone app?

Technically, with push notification the device should not experiment disconnections. The app “wakes up” when a call comes in.

If he is using another app with no push notification, then there can be several parameters. Like does the application run properly in background, is the battery optimization disabled, etc. This is different for every app.

Kind regards,
Alexandre

Hi Alexandre,
The failing phone also uses GroundWire. I suppose with push notification…I’m not sure how to check that.

The user receives calls just fine, as long as the phone is shown as “registered” at VoIP.ms. But after some number of hours, something goes wrong, and the status goes to “no registration found” and then the phone no longer receives calls. Launching Groundwire puts everything right again.

Hi Steve (@aerosol),

I just bought GroundWire (and quite happy about it) and I see two things that can be tested.

First, I see that when GroundWire is closed, it triggers the “Push” notifications on (you see a message in Android’s notification bar for a few seconds). When GroundWire is open, then it registers directly to the sip server.

Maybe there is a case where the application is still open, but then Android’s battery optimization stuff makes GroundWire unresponsive, or disconnect the network, etc. This is a supposition after observing this behaviour. (I had no issues so far, but every device has little things configured that makes it behave differently.)

So one suggestion would be to try to activate (or test) one of the following (or both):

—Settings → Network → Prevent Wi-Fi from sleeping

—Settings → Permissions → Ignore Battery Optimization

Maybe one or the other or both can help in this specific case.

Then you can make sure that all account settings and other settings in GroundWire are the same between this device and another working one.

Kind regards,
Alexandre

2 Likes

Hi Alexandre,
Thank you for the suggestions. The “ignore battery” was already set. However, the user found that Push Notification was not turned on. Changing that solved the problem.
–steve