Just a rant, doubt there is any solution to it

First a question, is that ‘DID Portability’ section in VoipMS portal used to transfer DID #s to another competing voip services provider? Also if you move away from voip ms, can I get my credit back?

I ask because I’ve just about had it with this service. I use it minimally by any standard, not like people nowadays who are virtually married to their phones, 24/7/365

But phones (soft and hardware) registrations are so bad, I only stayed for many years with it because of phones being fairly secondary to me and because of the inertia, not wanting to deal with it.

To start with, the portal panel where it shows your registered phones is not updating properly. For ages I used toronto1.voip.ms server. At least that’s how it is listed, but I was only ever able to register phone on it by using toronto.voip.ms (without the ‘1’ in there)!!

I suppose it is the same, with 1 or without it, as somewhere on portal it is without but mostly with the ‘1’.
BTW I think I started using voipms maybe from its very first start, when there was only this one Toronto server available.

This week I decided to change server to toronto4.voip.ms (4 because my older softphone on mobile phone has preset choices for servers and only up to 4, originally I wanted to try toronto7.voip.ms because I regard #7 as a sort of lucky number LOL

After changing to this server #4, the portal only shows 4 for one of my mobile phone, the other phones including the hardware ones are stubbornly set to toronto1 for several days now - even when the phone is registered on new server # for some time before the registration fails (I know there is some few minutes delay and all that stuff needs to propagate).

This mess with registration server numbers resulted in my being unable to phone between my subaccounts and even my main account now doesn’t receive DID calls (they are not declined and ring as normal) when the phone is registered (my hardware phone). I suspect it is all because the registration servers are now totally confused in the settings in my account after I switched from that server 1 to 4.

IMO the website is antiquated since it is more or less the same acct settings layout like decade ago when the service started, confusing in some parts of it. It really needs to be brought up to the times. And I don’t mean spiffy it up for simpletons, just don’t show me this DID server table on my account setting when I am not ordering new DID but configuring the one I have.

Instead, it tells you any changes you make here won’t apply to your existing DIDs, for that you must go ‘here’. WHY have this table here and not the one that apply to my acct DIDs?? This is just one thing, the portal could use logical reordering like a pig needs a scratching.

My phones are refusing to register and when they are registered, they can lose the registration anytime. I have several of these older hardware phones, Nortel 1534 but googling this now doesn’t show the exact image of them, I guess it is quite a few years since the voipms started out, I think I got those phones about that time.

This voip service very much reminds me of the times back in 97 when I went with my brother to university library to see what this internet thing is about. It was like molases and we just looked at each other and left, was like newborn baby that couldn’t do a thing, not even this thing they drop at the bottom and cry, just be stuck on loading LOL

Hello @vane171,

There is a solution, I am sure. It feels like you might have a simple setup problem, and the tech support could help you fix all that.

I am using voip.ms services for businesses and homes, and it works flawlessly since many years. The website UI is technically complete, but maybe not easy to go around, at first at least. (Much better than some PBX I have seen in the past, and command line config files! :blush:)

Are you using your main account?

  • I am not, for security reasons, and so I rarely go in the “Account Setting” which is in part to setup the main account and the general system. This part is the most confusing, but nothing has changed in years in this regard, this is how they made their interface.
  • I prefer to setup a subaccounts for any device I need, never using the main account. It keeps things simpler to manage and understand, as far as I am concerned. So one subaccount per device.

There are two very basic setup instructions:

  1. Set the POP server of your DID.
  2. Use the same server for the devices (each subaccount).

Personnal tip concerning servers: I live in the area of Montreal and never was able in the past to use the Montreal servers in a stable way, nor Toronto servers. It seems the internet routes were not good. I went for a New-York server many years ago and it works well for me. For other homes/business, I was able to use Toronto, etc. Their routes were working great. Maybe just try to change the server. (I say that from past experience, and cannot say if it would be the case today.)

The other tip would be to use SSL connections because it dramatically simplifies potential network issues. If your device allows it, use SSL! You must follow the instructions on the wiki as it is easy to forget a little detail that will make it fail. It is worth the trouble to make it work as it will most probably make your setup way simpler.

So make sure you have a subaccount for each device, set your DID pop server, setup your clients to use the same server (must be done for each client), and use SSL to simplify potential network issues.

Unless you have a terrible internet connection, it should work. When I was with cable-internet providers, I have more connection issues. (Once in a while, not that terrible, but now that I am on fibre, I see a difference.)

I hope these few lines can be of any help. :blush:

Kind regards.

Hi vane171,

as a long-time user I can only confirm what @aleclerc writes. Likewise, I used to use sub accounts to manage all my phone numbers - specifically, one subaccount for each number in service. More recently, as an experient, I have been using filter rule sets for some of my numbers without assigning them to a subaccount - either approach works under the right circumstances.

As to confusing aspects of the interface: I agree, there are some. Old? As long as it works why ask for something new? The interface loads fast and is not clogged up with scripts, and thank heavens it does not come in this ubiquitous contemporary design of “light blue writing on even lighter blue background” and oversized fonts that spreads out a page over several screen scrolls. But let’s not argue about what might come down to a matter of taste.

I have always been a pay-as-you-go user (I never had the call volume that would have warranted monthly plans), and after trying a few other providers over the years (in addition to VOIP.MS), I know that in the pay-as-you-go arena the combination of availability and fine-tuneability of diverse service details on one hand and the low cost of pay-as-you-go operation on the other hand is not even close to being matched by any other provider (even right now I am testing yet another provider’s pay-as-you-go service, and with them some - at least for me - important service aspects, such as encrypted connections and date-time rules, are only available to base plan users and not pay-as-you-go users).

I find that bad (missing, dropping, outdated) registrations are quite rare, so I suspect there are some parameters at play in your situation that warrant detailed investigation. And if a registration ever stayed on the “wrong” server after I changed it, it was a matter of 10 minutes or so, and then the issue was no longer (mind you, it helps to apply page refreshes or even go through a quick logout and new login to get up-to-date information fast). With good lease time settings an outdated registration should not persist for days…


1 Like

I too have used Voip.Ms for myself and perhaps 10 other people here (in their own accounts) and am not seeingt he problems you are. Being Mid-Pacific I can have latency issues toany server on the mainland. My phones here all use SanJose, LA or a few others and I can set them for various numbered servers.I would think that my unique location would have more issues than you have had.

Are you manua;ly changinmg the server on your mobile phones or are you using a selection provided by that software? Programs like Zoiper allowed me to specify a particular server.

1 Like

@amateur: Yes, I think the same. Also, you bring a good point about the registration timeout.

Are you part of the Beta Test of the servers?

I have my one DID # routed to my main acct. but that phone is mostly offline and I set up forwarding calls (failover) under all conditions, like offline, no answer etc. to one subaccount.

I have three other subaccounts and those are solely used to call between them.

But my problems has to do with registrations. I recall that years ago when I was first registering my hardware phones, port 60 didn’t work, I think I had to change it to 62 to register those phones at all, still remember the frustration. But from memory, that port 60 was not blocked by the ISP, it just didn’t work and at the time, I thought it either didn’t work with voipms or more likely with my phones, for whatever reason. I kept changing phone configurations so many times before figuring out to change the SIP port that it made me sick (some phones don’t have the easiest access to configuration).

I will change the DID routing directly to one subaccount to make things more simple. Without going into the settings on voipms portal, I am not sure if there is also failover settings to another subaccount.
The idea is to route DID to a hardware phone (first subaccount) and route failover to a mobile soft phone (second subaccount). The mobile phone is allowed to use only my LAN WIFI internet, no data over cellular connection.

The idea is that the hardware phone has more chance staying registered because mobile phone while roaming can drop it. And it is possible that the softphone is simply failing on newer hardware, even if it does work at times. I have to explore the paid softphones suggested here on another thread.

I understand that Android supports SIP calling natively, but some phone makers don’t allow that on their phones (doesn’t work on mine) and they would need to be unlocked to have that ability (whenever in the past I researched phone unlocking, I ran into dead end one way or another and never unlocked any). If that Android SIP calling would work, that would be the ideal free softphone, right? Maybe it is basic SIP calling without many features but as long as it would work, it would be fine for my use.

Thanks all of you for the replies, I didn’t make much constructive post, mainly to went my despair. Common sense tells me it must work at voipms end since otherwise they would be out of business if others, not even all, were experiencing the same problems.

And once you have longstanding problems, even the smaller shortcomings about portal settings get on one’s nerves. I also would say, it it works, that’s what counts and its OK if it looks like it was last updated sometimes back in the nineties.

What is most damming is that registrations refresh button. I must have some severe problems at my end because it is hard to believe the lag regarding its updating, how it reflects the real situation at my end (allowing several minutes for the propagation of any change made). Sometimes it works almost right away but only for some subaccounts.

I have completely failed trying to switch to toronto4.voip.ms server. Only my newest mobile phone registered and showed this server in the portal, all the other ones kept showing stubbornly toronto1.voip.ms no mater what. Result was that calling btw extensions didn’t work.

I fell back on my old server and now it all works.
BTW in the phones registration setting, it needs to be toronto.voip.ms without the ‘1’ , at least that did it for me. It is probably the legacy from the days when voipms was starting out and they had just this one server, so using ‘1’ wasn’t necessary.

Somehow I don’t have choice of NY servers, just Canadian ones, Toronto, Montreal, Vancouver…

My two other phones (hardware Nortel 1535), while they now register and calling works, they have problem showing up as registered in the portal. I suppose that is not too important as long as the calling works.
One of them does show up as registered after like half an hour but then after some time, it again shows as not registered.
Edit: I believe I sorted this one out, my username and display names were set to main acct while authentication name was the name of subaccount, or something like that.

Thank you all so much for replying, namely to @aleclerc
I took the advice of not registering anything to my main account and use just subaccounts.

I have a question. I have enabled SMS for my DID and in past was able to receive messages sent to my DID #
However now that I made calling working again, I tried to test SMS sending but it seems you either can’t send SMS btw two subaccounts, or I don’t know the number format.
I tried to use just the extension number, also that extension number with the registration server, like 1020@toronto.voip.ms but it doesn’t work. Also tried to send SMS to my DID number but also failed. I do hope SMS sent to my DID from external services out there will work since I need that for those various confirmations, like for banking etc. security confirmation.

OK, I installed VoIP.ms SMS app and made it work, it received some older confirmation messages I didn’t receive when I needed to receive them…

I tried to use this app to send SMS to my other phone, to its extension number, both registered on subaccounts. I clicked the red circle near the bottom at right which looked like for composing new message, I put in the extension number which is four digits but then I don’t know how to write the message, I am stuck on the address. Maybe because it expects normal ph. number like my DID, for example?

Or maybe this app is only meant to receive SMS?

Regarding toronto.voip.ms vs toronto1.voip.ms, they have the same IP:

toronto.voip.ms.        300     IN      A
toronto1.voip.ms.       300     IN      A

However, if you’re using encryption with a certificate then you don’t just need the correct IP, you need the common name / alt name on the certificate to match what you’ve configurated in your client.

The new (beta) server is probably a good choice if you’re able to move everything over at once, anycast is usually pretty good at selecting a “good” choice even if it isn’t always ideal, and it seems like it should solve the issues of calling from one server to another.

As far as porting your number out, you need to set a port out PIN, and then provide the new carrier the PIN as described here: https://wiki.voip.ms/article/Port_Out_PIN

The FAQ says for all new deposits made within ninety (90) days of such request of refund. If you’ve got an amount that is worth the hassle and is outside the 90 day window, either stick around and use it up, or ask their support team if they’d be able to transfer credit to another account and perhapsit won’t goto waste if you can work something out.

With all of that being said, having used a variety of the wholesale VoIP providers, VoIP.ms really is the way to go. The interface is a bit janky, but with that comes a lot of flexibility and configurability. Like others said, if you use subaccounts for everything and pretend the main account doesn’t exist then life gets much easier as you can apply changes to just one subaccount or all, although it is a bit janky (for example, you can’t globally change your POPs if you restrict them).

You still need to update the devices/softphones to change servers though, as well as updating the selected POP in VoIP.ms, if they don’t match then inbound calls will not see your registration.

1 Like

Hello @vane171,

Glad you made progress in solving the issues one after the other.

Android SIP calling — It was working well for a couple of years with old android versions, but it is no more supported in recent versions. Also, it never supported SSL (secured) SIP connections. I would avoid. Using a good app that supports SIP is now the best solution I think.

Registration delays — It is instantaneous on my side when I click the refresh button in the main (home) screen. So maybe there is an issue. Again, if you are not using TLS, I would recommend since it is reducing firewall/packets problems and other network issues to a strict minimum. SSL, even if hard to get to work at first (sometimes) is really the best way to go. Then, also, reduce the registration refresh time from 3600 sec (1 hour) to something more manageable like 300 sec (5 min). This must be done on the device side.

Toronto servers — If you have connection stability issues, try other servers (not Toronto, change area completely). Sometimes you might have a bad IP route for whatever reasons. (It happened to me in the past: unstable connection to Montreal servers, excellent connection to New York servers.) Must be due to the ISP infrastructure. I have no other explanations. And this was pre-TLS times.

Choice of servers — This is too bad if you cannot enter the IP address or domain name of a server, but must select from a list of choices in your softphone/device. Maybe too old. If you have the luxury of that, try to get one that would give you this possibility.

Question: SMS — SMS work on a DID, you cannot use them from one extension to another extension, under the same DID (phone number). You must configure your DID to know what to do when it receives an SMS. Choices are like forward to another phone number, or a specific subaccount, or an email address. This works all well. From any device you can send SMS to other phone numbers, no problem, but only using valid DID under your account. It truly is a DID to DID service.

SMS are either working or not. Some websites (using 2-factor authentication) are working and some others are not. Sending an SMS to a number is usually working, some are not. But this is not “random.” It will either always work to and from a number, or not at all. I do not know why. But if it works, you can be certain it will always work. So far with my experience with SMS.

One advantage of Voip.ms SMS is that you can see all the history of all exchanges, whatever the device you used to send sn SMS.

So yes, you can send SMS to another phone number, but not an internal extension. And if you try to send it to yourself, it will fail, if my memory is good.

Good luck! :blush:


Thanks for info, I didn’t think to look the IP up. Somehow when I did try with the ‘1’ in the name, the phones didn’t seem to want to register.

Now after I refreshed all settings on my phones, taking advice given here, I finally have a reliable calling. I am going to stay with voipms.

What made me come here to make a rant was the last drop when I had Rogers TV tech scheduled to come to service unsatisfactory TV service and on the day my phone that gets calls from my DID and receive SMS couldn’t register, with the result the co cancelled the appointment since I didn’t confirm it by replying to their SMS… Another problem was always receiving SMS confirmation when logging into banking, it was very unnerving every time, wondering if the phone will be able to receive SMS.

As per tip on another thread here, I got ‘PortSIP UC’ free softphone which works on my new mobile phone and is free of ads :hugs: kudos to the maker.

But several times I found that when the phone is not used for hours, it doesn’t receive calls to it (I believe I left the app running but will have to check on it). It says the number is not available to receive the call or something to that effect.

I will check in settings if there is something to keep it alive or maybe will consider paying ten dollars for the Acrobits softphone. That one people say has working push notifications and I suppose that means it stays registered and active all the time in the background, than it pops up a message when it receives SMS

That is all great info. As insurance, I added my email to have SMS sent to it, for backup.

I have SMS forwarded to subaccount. But I noticed that if I don’t register a phone to my main account and only use subaccounts, I can’t pass the SMS to another subaccount phone if the one receiving SMS is offline for whatever reason (or don’t answer etc.) There is ‘failover’ setting for subaccounts to forward the SMS or a call to another subaccount extension.
Failover appears to be only a feature for main account registration. That might make me rethink to have all phones on subaccounts, leaving the main account unregistered.

This is the very reason why you want push notifications. The reason is that android is saving your battery power by stopping applications working for nothing. You must tell android to always keep the application running (deactivating battery optimization features). There might also be an option in PortSIP UC. Doing this will give you higher reliability but will drain your batteries more quickly. Do not be surprised if you have the impression that your phone needs to be charged more often.

This is one of the reasons why I went with Groundwire: push notification. It. Just. Work. Reliability is super excellent; I never missed a call (except when totally off any data network). I was roaming few days ago, on the road, and calls were getting in; in the car! :blush:

1 Like

There is no “failover” but technically, when the device comes back online, you should receive the SMS.

For SMS I would really suggest using Voip.ms SMS application. You never miss an SMS with this because it uses voip.ms API to get all the messages on the server, sent and received. It gives 100% reliability.

Any other device might potentially have holes in SMS history. For example, if you use two devices to send SMS, the sent SMS will be visible only on the device it was sent from. But Voip.ms SMS will show the full thread all the time.

Another example is if the device (subaccount) where SMS are forwarded to is offline, you might have lost messages, depending on how the device handles such cases. (I think on voip.ms side it holds the messages until it can be forwarded; a simple test can be made in this regard.) But again with the Voip.ms SMS app, using the API, you get the listing of everything.

In the course of troubleshooting phone registrations, I did install that Voip.ms SMS app, it is a sure way to get SMS even if phones are offline. The app interface makes it clear which SMS is the most recent one, on the phones I often can’t tell if the just arrived SMS is at the bottom of screen or at the top (I think it differs phone to phone). Need to read the date or the time to be able to tell which is the one that just arrived. At times I used wrong code to confirm login because the phone message interface is so confusing (no graphical borders btw messages, can’t tell at a glance which is the newest SMS). Once I input not an older code but other numeric string in the message… it should all be clear at just a glance.

Thanks for confirming what this ‘push notification’ is about. I have just tested again and calls from one subaccount to another that has that PortSIP UC registered yield first the 480 reply, then a number of 486 ‘busy’ replies. Not sure how to fix this since the phone is not busy (on call) and I can call from it to that first subaccount.

480 /Temporarily Unavailable
486 /Busy Here

Ironically, that first subaccount is on an old Android phone that can only have the old softphone CSIP Simple installed. It is actually more reliable to stay registered and I never get those 480 or 486 messages on it. Only fault it has was the registration problems I had but those are now solved.

Moreover, on CSIP Simple I can deactivate registration whereas PortSIP UC give me no control whatever over registration. It does have "log off: ‘my email’ " in its settings which I don’t know what it might do but my email has nothing to do with registration on the server.

This Groundwire looks to be a sister app to Acrobits app. Groundwire is business phone and compared to Acrobits, it has Messages and Conferencing as additional features (messages is probably btw phones that have installed Groundwire).

But both cost almost the same amount, $10 vs $12 and the question is, why would people get Acrobits if the cost difference is minimal and you get more features with Groundwire?

Is it maybe the phones interface? Like business phone has a boring business like look whereas Acrobits has some nice spiffy, nice to look at interface?

PortSIP UC was working well for me, but I used TLS connections. Are you using TLS connections? (And if you do make sure you have every little detail setup, like the RTSP setting which can be easily forgotten.) I had nothing to say, except personal taste on the incoming call UI and the battery drain.

Yes, they have Groundwire and Acrobits which has fewer features. I wanted to be able to do call transfer very easily (instead of messing around with key commands I always forget).

As for the UI, I think both applications share the same UI. I just checked the screenshots on Google Play and I think they are outdated. Groundwire looks more like the Acrobits screenshots (like the 3 colour buttons to answer, with a nice colourful background).

Kind regards,

1 Like

Those two failed calls messages (480 & 486) are due to some glitch.
Either I have misconfigured my subaccounts or there is some mixup.

I just found that my older mobile phone registered to subaccount with CSIPSimple rings on two different internal extension numbers, those of the 10## type.
One extension is its own, that’s OK but it also rings on the extension that belongs to the phone with the PortSIP UC
How could that happen? :worried:

Of course I get the 486 Busy or 480 Not Available messages when I try to call the phone with the PortSIP UC. That’s because I am actually calling my own internal extension 10## number.

This is internal extension number for CSIPSimple

And this is internal extension number for PortSIP UC

But both these internal extension numbers, the 1041 & 1080 now ring the old mobile with CSIPSimple which has 1041 assigned to it and should ring only on 1041, not when I call 1080 from other phones, including the one with the PortSIP UC installed.
I clicked the Update Account for both of these subaccounts and re-registered the phones but still one phone rings on two internal extension numbers while the other apparently has no internal extension assigned to it. I am stumped.

In this connection I want to mention that PortSIP UC softphone has no way to deregister apart from quitting the app and starting it again, at least I think that does it. I don’t like it when you get no explicit control over basic things like this. At least I don’t see any obvious way to deregister it.

I think I have to delete those subaccounts and make new ones. Hopefully I can use the same subaccount names, they they will not be ‘already taken’ and cannot be reused…

Indeed, you can delete and recreate. Using the same names will not be a problem.

That being said, is it possible that there are two SIP accounts registered on your phones? Maybe in the same app, or maybe you have multiple apps installed with one or the other account. This would explain why the same phone rings on both calls.

Make sure that in your applications you set the registration timeout at 5 minutes (300 sec). This will help you avoid very long registration issues. Another way to “drop” a registration that is incorrect on voip.ms side is simply modifying the subaccount. This will cause a registration drop within a very short time. (I do not think this is a feature (?) but I have seen this behaviour.)

Kind regards.

1 Like

I don’t have two registrations on one phone, in particular on that one that rings on two different subaccount internal extension numbers.

It is very clear in the settings where you see VoipMS icon for the account and a button with a plus sign to add another acct. if I wanted a second one.

You’re right, changing anything in the portal does drop the registration for a while.

I’ll remake the two subaccounts and if the mix up should persist, I will try different subaccount names and let you know how it went.

1 Like