Call Audio Dropping Using Linux and Softphone

I am using Linux and use JAMI to place calls with TLS. This is in a desktop environment.

I am having call audio periodically completely drop. I am not referring to subpar audio or something like that. I don’t really care if the audio is perfect.

When the audio drops, the strange thing is that others can hear me and I can’t hear them at all and the audio completely drops and doesn’t return. So outgoing audio is fine, incoming audio is not there at all. Also, the audio usually doesn’t drop until after about 10 minutes, so for short calls it’s not problematic, but for longer calls it is.

I have chatted with technical support and they have suggested it could be a firewall issue. I am not completely savy with firewalls and how they function. I did experiment with unblocking certain ports on a hardware level and it didn’t do anything. I have made adjustments to JAMI that were suggested by and have still had the problems.

If this is an issue with JAMI, I could try linphone or something else. I would be willing to purchase a softphone if thtat makes a difference, but I am not sure it will. TLS is important to me to protect the calls. Does anyone else using linux and a softphone have suggestions?

I have also used twinkle before with another voip provider with the same desktop and didn’t have this situation, but left the other voip provider because TLS wasn’t an option. Twinkle does not have TLS included, from my understanding.

i figured it out after contacting support again. i just needed to change to a protocol that used less kbps and did that in the portal and the problem stopped.

I somehow thought it was a firewall issue, but the issue was that when there’s a lot of packet loss either the soft phone or the protocol or some piece of the equation just gives up. I also switched to linphone and am happier with it.

Just putting this here in case someone else has the same problem.

1 Like

Hello sipper,

We greatly appreciate all the effort you put into troubleshooting, and we also appreciate you sharing the information on the forum. Thank you.