Softphone App Incoming Not Working

Using ‘Softphone’ app on iPhone. Works like a charm on outgoing calls. However, it does not respond at all to anything incoming.
Any notion on what I’m doing wrong?

I had the same problem with linphone. I’m thinking it is something big and obvious that I’m missing in the process, as I’m not an expert.

Yes. Thnx for response. Hopefully someone smarter than us has a suggestion.

A possibility: in the Softphone app, is the server the same server as selected for the subaccount (or DID if you don’t have subaccounts)? So in the interface under DID Numbers > Manage DID(s) > DID Point of Presence, so if you selected “” here, do you have in the Softphone app?

Thnx for suggestion. Server name is the same.

Colin, when you say “softphone” are you referring to apps in general for making phone calls? Or to this specific app by Mobyx Software that is called “Softphone”? If the latter, the description for Mobyx Softphone says you have to have a voip line with Mobyx. If not Mobyx Softphone, which softphone app are you using?.

Hello @Colin1,

This can be many things. Have you checked if there is a wiki entry for your specific software? (See

If your application can work with TLS/SRTP, I would recommend using that as it is the best way to minimize the number of possible issues. My experience is that using TLS and SRTP is the easiest way to go. (Sometimes a bit tricky to configure, but very stable after.)

Kind regards,

Thnx for idea. I have tried following the wiki. As said, outgoing calls work perfectly. No reaction at all to incoming …

I’m using ‘Softphone’ by SessionTalk (which a voip rep once recommended).

Colin, some more ideas:
Have you tried uninstalling SessionTalk Softphone, re-install and doing the setup for again? Sometimes that works for me and even though I think I’m doing exactly the setup, somehow the softphone then works.

Also does SessionTalk Softphone offer a template for If so, enter only the three basic pieces of info, account name, password, server.

Test with another softphone? LinPhone works well, it’s open source so fully functional out of the box.

What transport protocol is SessionTalk set to? I checked my software, it’s UDP.

What happens if you make an outgoing call then immediately call the softphone (so it doesn’t have time to time out and unregister)?

What is the keep alive set at? The wiki suggests 300 seconds/5 minutes.

Appreciate the ideas. Using UDP and have changed keep alive to 300 seconds. No difference yet. I’ll try LinPhone …

Thinking of all the things in the past I tried to resolve an non-functioning softphone. One more idea: setup and use a new subaccount for the softphone. I don’t know why but it sometimes works and I think I’m doing things exactly the same, taking all the defaults. The trouble seems to be on the softphone’s side, not’ side.

Hi @Colin1,

Using UDP will make you run into a lot of troubles. Again, if it is not the case yet, use TCP over TLS with SRTP properly configured on your device. You should then be able to receive calls across many different network situations (mobile data, public wifi, home wifi).

Kind regards,
Alexandre :slight_smile:

Many thnx. Will try.

Thnx. Yes, seems to work just fine. I’ll try with sub …

To go off on a tangent on Colin’s post, will using TCP solve the problem of message parts of long sms arrive in the correct order? Currently sending or receiving long sms which often arrive in multiple parts in the wrong sequence, say an SMS by its length is broken into two parts but the second part arrives before the first part. Or TCP is more to prevent data loss?

Hi @Tonyv,

For sending, I do not know, but for receiving SMS, from my experience, unfortunately no. They can still arrive in disorder. The only place I can see the SMS pieces in order is via the SMS portal or through the API.

1 Like