Polycom VVX500 does not ring when called

I setup my voip.ms account and everything works great to a Grandstream ATA and all home phones work perfectly. I have an IP based phone, Polycom VVX500 that I setup according to the wiki. It registers and can make calls internal and external. But if I call it, it never rings.

I thought it was the power save mode becuase I would see an “Off hours mode” in the top right, but I disabled all power saving features and now the phone does not say that.

Its registered via sip 5060. I’d love to try TLS to secure it, but one step at a time here. It works to place all internal extention calls (home ata cordless phones, ext 1000, zopier iphone app, ext 1002) but calling it at ext 1001 or calling the DID which has this subaccount in a ring group, it just doesnt ring.
Its ip address is dhcp, and I can get into the web gui. I even tried factory resetting the phone and setting it up fresh. Same great outbound call quality - but no ringing on internal calls. Nothing even displays. The caller just hears 4 rings until voicemail.

I googled a lot about this phone but I keep getting HP forums in google results. So I figured I’d try here. Its not the end of the world, I have a cordless home phone here too, but I thought it would be pretty neat having an IP phone on my desk. Its the latest Polycom firmware:

UC Software Version
Updater Version

I dont know if this fixed it or not, but three test calls got it to ring.

In the web gui under Preferences > Ringtones, expand Default ringtone and change ring type to something other than Default. I set it to Medium Double Trill.

Whats weird is if “Default” is silent, then why didnt the screen acknowledge a call was coming through or not before.

I’m not saying its fixed, but 3 test calls so far, it rang and I was able to answer.

By chance does the VVX500 have a “do not disturb” setting and it was activated? Second, what happens if you create a ring group with the VVX500 plus one or two other known-to-work phones (could even be a cellphone) and see if incoming calls sometimes ring the other phones but not the VVX500. That will tell you if incoming calls are being routed properly.

I checked today and there does not seem to be any DND mode on. I dialed my DID and it hit the ring group which rang my Grandstream ATA, but the polycom sat there and didnt do anything. The screen didn’t even indicate a call was coming through.

From my ATA I tried then dialing the Polycoms extention I gave it, 1001. Its ringing on the callers handset but the polycom is just sitting there. After 4 rings it goes to the assigned voicemail for that subaccount.

Now on the Polycom I can dial 1000 and it rings the phones off my Grandstream ATA no problem. I can dial any outbound number- no problem.

So the Polycom, which did recieve 3 test calls yesterday is again no longer receiving any calls today. Anyone have experience with Polycom VVX500?

Have you tried resetting the VVX500 to factory settings and setting up again for voip.ms? I find that sometimes solves problems with both hardware and softphones. I don’t know why but I reset to factory and start again, then the device or app works when it didn’t with what I thought was an identical setup attempt previously.

I did do that actually. I’m trying another thing now. I’m line 1 sip configuration I’m changing Subscription Expires from 300 to the Polycom default, 3600 (in seconds).

I’ll keep the regular “Expires” at 300 as recommended in the VoIP.ms wiki. My Grandstream ATA is set to 5 minutes which is the same as 300 seconds and there’s no issues at all with it.

I rebooted the phone and incoming calls are ringing now. I wonder in 3600 seconds if it will stop working.

I’ll test again tomorrow!

You know what I just noticed… for transport the VoIP.ms wiki says it should be (UDPOnly). Mines (DNSnaptr). Let me change that, reboot phone and see if it stays registered, and I’ll set both timeouts to 300 like the wiki said.

Maybe that’s all it is? That’s gotta be it!

I know at one point I tried TLS and it did register but couldn’t place calls. The wiki specifically states to disable all TLS stuff so that will be my next challenge, if and only if I can get a 100% stable base config.

The wiki also didn’t say much about TLS on the Grandstream ATA, but I figured it out on my own.

I have a Grandstream IP deskphone. Checked and my transport is UDP. Also I have the Expires set at 60 seconds. I don’t know if that’s excessive refresh but the phone has been functioning for many years with no issue.

I changed it back to

It eventually stopped ringing inbound. Outbound never a problem.

I then tried TLS like my GS ATA. Enabled it on sub acct. changed to TLS and port 5061. Enable / offer and require SRTP.

Phone registers fine. I can get phone calls no problem, but I can’t place calls. I get a fast busy trying to dial out. Weird because all inbound calls work great. Even have a lock icon on the phone.

Anyway I changed it all back to port 5060, undid the SRTP settings and back to UDP. So far it’s working, but I’ll see if it ever “expires out”.

On the voip.ms website you can see if a device is registered. This is on the Main Menu > Home page. When calls, whether incoming or outgoing fail, what’s the “registered” status of the VVX500?

Do you have any other device using port 5060?

Another question. is the VVX500 setup with the same DID Point of Presence as in your DID Numbers > Manage DIDs > (for that number) DID Point of Presence?

voip.ms shows the polycom is always registered. The polycom can always place a call on regular 5060 UDP. It just doens’t always ring when called.

My Grandstream ATA is on port 5061 using TLS. the only thing that may use 5060 is zopier, an iphone app, but thats only registered to voip.ms when the app is actually running. Iphones do not allow apps to multi-task. However when I reboot the polycom zopier on iphone can call the polycom OR my granstream ATA by its internal given extention.

(and vice versa, all devices can call all devices).

Yes all Newyork8. I have all 3 devices on subaccounts registered to the same server. I’m in Pennsylvania so I picked New York, its geographically close and my ISP has a pretty short hop that way. I decided on 8 becuase i didn’t want 1, figured it would be busy.

Phone shows it’s registered (blurred out my sub account name), it can make phone calls, but it doesn’t ring if I dial its extension or the main DID is dialed (it is in the ring group).

It worked last night before I went to bed (ringing).

The Polycom phone rang twice today for inbound DID call so it seems to be working again. I didn’t make any changes.

Later last night the polycom stopped ringing on inbound calls. Outbound calls were fine. It was not in DND or any other off hours / power save mode.

Its just a real hit or miss. Not sure how its different from my Grandstream ATA’s configuraiton. That seems reliable.


I’m having similar issues with inconsistent incoming calls on a Polycom Obi 2162. (I joined to post an issue, but saw yours first).

Suggest you you select, assign, and save the DID in the VOIP.MS sub-account menu for the account assigned to the Poly. I was pulling my hair out for days - I re-saved the DID assignment and incoming started working. (It did not appear there was a change to “save” but apparently I never assigned the DID to the sub-account).

I have read that TLS punches through NAT routers better - so I enabled it. If you want to try it follow the TLS directions in the Obi 100/110 & Obi 200. Make sure you enable SIP encryption in the VOIP.MS settings.

Everyone I have asked said that incoming call problems are related to firewall and NAT keep alive settings, I can’t quite crack the code yet. My incoming calls are fairly consistent now, but I have ring group issues.

Hope it helps.

As far as TLS yes, I’ve gone through that. Phone registers with TLS (lock icon on the calls). It can recieve calls, but when trying to place a call its a fast busy. Yes I do have Outbound Proxy filled in too:

I was on with support and seems the Polycom VVX500 doesnt reach voip.ms when TLS is on and I try to make an outbound call. I get a fast busy on the polycom but voip.ms isn’t getting the call. Oddly, I can call inbound to the Polycom, it rings, and theres high quality two way audio, along with a lock icon on the Polycom screen.

So theres something wrong with the Polycom VVX and how it does TLS. I changed it back to UDP for now.

Support had me try a few things like fix the codec to g.711… we tried alternate TLS ports, not just 5061, but also 5081. No real change.


I had this issue with another device (could receive calls, but fast busy when trying to place a call). My problem was as simple as SRTP was not set to “force/enabled/mandatory/required.” (It took me a long time to figure it out. Little details…)


Best regards,