Help with clustered POP beta: can't make or receive calls

For beta users, VOIP.MS has enabled the POP “Toronto Test”…

… as a test of a clustered POP. When I enter the new POP’s address into (A) my Grandstream GXP2130 desk phone and (B) the DID’s settings in my VOIP.MS dashboard, I can’t make or receive calls, either with or without TLS.

Does any of you have advice?

I am also gets testing this feature. I get incoming calls but cannot place outgoing calls. I submitted a support ticket.

if you have a main incoming number that is directed to a ring group, make sure the main number and all DIDs in the ring group are on the same POP ( or in this case, the new beta server cluster URL)

I also have tested the clustered POP Beta feature as described here …

DID pointing to Ring Group.
DID set to utilize (or
Applicable devices set to
POP restriction NOT enabled for sub-accounts.

After extensive delay, Authentication Type finally shows Register in green and tool tip shows as expected.

Internal extension calling succeeds.
Outbound calls succeed.
Inbound calls from a Free Fongo number succeeds.
Inbound calls from a Free TextNow number succeeds.
I do not have a PSTN service for testing inbound calls.
SMS sent and received on the DID are normal.
Call display is normal.

Inbound and outbound calls are now working. I have a DID going directly to a sub-account that’s on the clustered POP.

However, for inbound calls, the caller doesn’t hear any ringback sound while the phone rings. I’ve tried calling from VOIP.MS, Flowroute, T-Mobile, and Metaswitch: same result. So I think that there’s a small configuration problem with the clustered POP.