Anonymous calls getting black-holed?

My wife and I have a VoIP.ms DID which we use as a “home phone”. It routes to her cell phone by default.

Everything works fine when we receive a call from a US or Canadian number with the caller ID set: it gets forwarded to her cell phone.

However, when we receive a call from an “Anonymous” number, it seems to get totally black holed.

Here’s an example below from the CDR:

  • The first call (from 604-xyz-abcd, at 15:17) gets forwarded just fine.
  • The subsequent calls (from “Anonymous” at 16:10, 16:13, 16:19) seem to go straight to voicemail.
  • We did not make any changes to the settings in this time.

Is this a known issue? It’s causing us to miss calls from medical providers, etc. :sob:

Subsequently, I’ve tried changing almost every setting I can think of, and I’ve made a ton of test calls, but nothing works:

  • Regardless of the routing (forwarding to cell phone, forwarding to SIP account, forwarding to ring group), anonymous calls go straight to voicemail.
  • Even if I create a custom Caller ID filter specifically for Anonymous callers, they go straight to voicemail.
1 Like

I found this buried in the wiki:

https://wiki.voip.ms/article/Caller_ID#Outbound_caller_ID_number_using_Call_Forwarding

“if the incoming caller is hiding their phone number this call will fail due to the new regulations for CID, on where sending a valid caller ID number is mandatory.”

So by default calls without valid caller ID will get black-holed?

And there’s no way to receive those calls, except to make the forwarding phone number override caller ID for all calls received on that phone?

1 Like

Hello dlenski,

At the moment this is correct, due regulations over the callerid for hidden or anonymous callerID the only work around is to manage a call forwarding with CallerID override set, now when using the callerID filtering tool, you can set this up ONLY for those calls that reach you out with the callerid information in this form.

We understand this might not be optimal, however this is a workaround to be able to receive those calls for now.

Incoming calls with valid callerID information would not be affected and won’t require any special configuration.

What regulations are you referring to, exactly?

  • My phone with a USA number can receive calls with hidden/anonymous caller-ID just fine.
  • My Canadian cell phone number can receive calls with hidden/anonymous caller-ID just fine.

I’ve tried to do this and it seems impossible to achieve the following:

  1. Calls with caller-ID information get forwarded to my cell phone with the original caller-ID information.
  2. Calls without caller-ID information get forwarded to my cell phone with the override caller-ID set.

This appears to be impossible due to the fact that I can’t create multiple call forwardings targeting the same destination number.

Am I missing something?

The fact that calls with anonymous/hidden caller-ID go straight to voicemail by default seems extremely sub-optimal to me.

As far as I can tell, this is not described or disclosed anywhere except deep within the wiki.

This makes it extremely hard to recommend VoIP.ms as a “home phone” replacement given the prevalence of businesses which call without caller-ID.

Why can’t VoIP.ms provide a “replacement caller-ID” for such numbers (e.g. 999-999-9999) by default?

Hello dlenski,

Back in 2022 new regulations over callerID information was applied for our service, also following the guideliness from our carriers, where valid information is required for incoming and outgoing calls to ensure connectivity.

This appears to be impossible due to the fact that I can’t create multiple call forwardings targeting the same destination number.

This is not correct, you can create multiple call forwardings using the same number , one of the purposes is specifically to use the callerid filtering, this way you can setup the filter for anonymous callers into the modified call forwarding and use the regular call forwarding in a different way.

The fact that calls with anonymous/hidden caller-ID go straight to voicemail by default seems extremely sub-optimal to me.

With proper configuration this should not occur and should take path the route set in the callerId filtering instead of just going into VM

In this sense what you aim to is, to have the anonymous callers forwarded and reaching the route set correctly , the only difference would be that they will have the callerID override set instead of displaying anonymous

Anything you can point to in terms of public information on these regulations?

I tried to do exactly that, but when I attempt to add a second call forwarding to the same (target) number, I get the error that “The number you provided is already in use”.

Given that the form in question contains at least 2 different phone numbers, I’m unsure which one “the number you provided” refers to, but I’m pretty sure that it’s saying I can’t create multiple forwardings to the same (target) number since it happens with multiple different options for caller-ID override:

Hello dlenski

Ill double check for all the information required and provided and comeback with you asap. Thanks for the inquiries.

I was able to duplicate the record this way, one record with 1 in front, and the second record without 1 in front, this might only work for US/CAN as long as you have dialing mode NANPA on the account settings. In addition this is only a workaround.

As I verified there is a limitation with the call forwarding entries as you confirmed, in this moment.

I would think any provider of medical would not use Anonymous as caller ID. I would confirm with the provider. I have a Poly 402 ATA and have setup VOIP.MS to play a message to users who “block” caller ID (Enter *67) so those calls are received but tells caller to not block their number. I tested it with my cell. Is it possible you have a filter enabled?
I love the Anonymous is blocked and not routed as that has stopped 99% of the SPAM calls I was receiving on our number.

Reality disagrees with this.

We have at least two completely different medical providers here in Vancouver, BC who use a phone system that does not send caller ID.

Quick suggestion to solve your problem, instead of forwarding to a phone number, you could route to a sub-account, and then use a softphone to receive calls on your cellphone for this sub-account.